गूगल ऐडसेंस

Sunset Edition
This update of the plugin is the last publicly released version. We do not expect to make any serious changes or add new features to it from now on.

We may not always be able to provide prompt support for this plugin on the WordPress.org forums. If you would like to have professional support or extra/custom features, खरीदने पर विचार Ultra version

Ads EZ Plugin for Google AdSense provides a streamlined interface to deploy Google ads on your blog. You can customize the colors, sizes and placement of the ad blocks and activate them right from the plugin interface.The admin interface uses a highly functional and modern interface based on the twitter bootstrap framework with generous, context-sensitive help on every single option.

Live Demo

Google AdSense admin interface is feature-rich, उपयोगकर्ता के अनुकूल और कार्यात्मक. यह पूरी तरह से परिचालन कृपया यात्रा live demo site यह तुम्हारे लिए क्या कर सकते हैं देखने के लिए.

Ads EZ Plugin for Google AdSense is a specialized version of Google AdSense Ultra, which lets you manage in basic, standard and expert modes, all in a beautifully designed modern interface.

सुविधाएँ

  • रिच प्रदर्शन और संरेखण विकल्प.
  • प्रत्येक पोस्ट या पेज में स्थिति और विज्ञापन ब्लॉकों के प्रदर्शन पर नियंत्रण.
  • Customized Google interface with color pickers.
  • अपने साइडबार के लिए विजेट.
  • Beautifully designed, fully responsive, intuitive interface.
  • Inline editing and instant saving of your options with AJAX (no more form submit/refresh etc.)
  • An interface tour to familiarize yourself with the plugin features and layout.
  • Popover help for every option in the plugin.
  • Ability to spawn the plugin interface as a separate tab/window independent of the WordPress admin interface.
  • मजबूत codebase और विकल्प / वस्तु मॉडल.

प्रो संस्करण

Ads EZ Plugin for Google AdSense is the freely distributed version of a premium plugin. The Ultra version आप भी अधिक सुविधाएँ देता है.

  • Safe Content filter: To ensure that your Google AdSense ads show only on those pages that seem to comply with Google AdSense policies, कुछ टिप्पणियां उन नीतियों के साथ असंगत अपने पृष्ठों को प्रस्तुत कर सकते हैं के बाद से महत्वपूर्ण हो सकता है, जो.
  • IP filter: Ability to specify a list of computers where your ads will not be shown, अपने ही विज्ञापनों पर आकस्मिक क्लिक से बचने के क्रम में -- मुख्य कारणों ऐडसेंस की है कि आप पर रोक लगाई. These features will minimize your chance of getting banned.
  • Compatibility mode: To solve the issue of the ad insertion messing up your page appearances when using some themes.
  • Category/Post Control: Ability to suppress ads on specific categories, posts and pages.
  • Shortcode Support: Show the ads only on the pages or posts you want, and exactly where you want them.
  • Mobile Support: Ability to show different sets of ads on mobile devices, or to suppress ads.
  • Excerpts: Ability to show a configurable number of ads on Excerpts (which make up the home page in some themes).
  • Option Sets: Multiple option sets can be defined and easily switched between.
  • Suspend Ads: Ability to temporarily suppress ad serving.
  • Admin Interface Themes: Multiple color schemes for the admin interface.
  • Ad Serving Statistics: Keep an eye on your ad serving statistics to make sure that Google is not shortchanging you. (Optional paid module)
  • Basic/Expert Modes: You can choose to operate it in basic or expert modes in addition to the standard mode.

The Ultra version costs $9.45 और हो सकता है ऑनलाइन खरीदा तत्काल डाउनलोड लिंक के साथ.

स्थापना

Searching

इस प्लगइन स्थापित करने के लिए सबसे आसान तरीका है WordPress व्यवस्थापक इंटरफ़ेस का उपयोग करने के लिए है. आपके व्यवस्थापक डैशबोर्ड पर जाएँ, लगता है "प्लगिन्स" मेनू, और पर क्लिक करें "नई जोड़ें". Search for this plugin and click on "अब स्थापित" और वर्डप्रेस निर्देशों का पालन करें.

Uploading

आप स्वयं इसे डाउनलोड करने और चाहते हैं स्थापित, आप फिर डैशबोर्ड इंटरफ़ेस का उपयोग कर सकते हैं. सबसे पहले अपने स्थानीय कंप्यूटर के लिए प्लगइन ज़िप फ़ाइल डाउनलोड. फिर अपने व्यवस्थापक डैशबोर्ड के लिए जाना, लगता है "प्लगिन्स" मेनू, और पर क्लिक करें "नई जोड़ें". पर क्लिक करने के बाद "नई जोड़ें" ऊपर के रूप में मेनू आइटम, पर क्लिक करें "अपलोड" (शीर्षक के नीचे "Plugins स्थापित" शीर्ष के पास). अपने डाउनलोड ज़िप फ़ाइल के लिए ब्राउज़ करें, यह अपलोड और प्लगइन सक्रिय.

Using Plugin Interface

Further updates (and Pro upgrades and module installations) to the plugin can be done easily from the plugin admin page itself, by clicking on the Updates button on the top right corner.

प्लगइन के व्यावसायिक संस्करण स्थापित करने के लिए, लाइट संस्करण deactivage कृपया (यदि कोई हो) पहले. तब ज़िप फाइल अपलोड कि आप डाउनलोड WordPress व्यवस्थापक इंटरफ़ेस का उपयोग कर अपनी खरीद नीचे दिखाया के बाद.

[install]

प्लगइन है अद्यतन यह भी उसी प्रक्रिया का पालन करते हुए, अधिमानतः प्लगइन व्यवस्थापक पृष्ठ से एक अद्यतन के लिए तैयार है जब आप एक फाइल अपलोड फार्म देखेंगे जहां. अपनी खरीदी प्लगइन के लिए पहली अद्यतन हमेशा स्वतंत्र है.

स्क्रीनशॉट

  1. गूगल ऐडसेंस के लिए विज्ञापन ईज़ी प्लगइन "अवलोकन" टैब और nbsp;. और nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 1
  2. How to set the options for Ads EZ Plugin for Google AdSense.  Screenshot [ads-ez-plugin-for-google-adsense] 2
  3. Advanced configuration of the plugin.  Screenshot [ads-ez-plugin-for-google-adsense] 3
  4. Options to support safety, compatibility, mobile devices and category/post control.  Screenshot [ads-ez-plugin-for-google-adsense] 4

परिवर्तन लॉग

  • V4.20: Compatibility with WP4.8. Sunset edition. [अगस्त 1, 2017]
  • V4.10: WP4.6 के साथ संगतता. कई संचित फिक्स और परिवर्तन. सूर्यास्त संस्करण जारी. [अक्टूबर 12, 2016]
  • V4.00: Compatibility with WP4.5. [अप्रैल 12, 2016]
  • V3.98: Improvements in the Google Translator interface. Compatibility with multisite installaton of subdomain type. [फ़रवरी 28, 2016]
  • V3.97: Minor interface and documentation changes. [फ़रवरी 25, 2016]
  • V3.95: Work-around for servers that refuse to save ad code because of the script tag. [फ़रवरी 18, 2016]
  • V3.94: Restricting Google Translate not to translate user-editable strings. Optimizing screenshots. [फ़रवरी 7, 2016]
  • V3.94: Ensuring widget titles can be suppressed in Easy AdSense. [जनवरी 27, 2016]
  • V3.93: Adding diagnostic information on the update page. [जनवरी 20, 2016]
  • V3.92: Changes to make the plugin compatible with multisite installations. [जनवरी 14, 2016]
  • V3.91: Adding a dev-friendly include to introduce local settings, यदि कोई हो. [दिस. 30, 2015]
  • V3.90: Compatibility with WordPress 4.4. [दिस. 5, 2015]
  • V3.82: Making the admin menu dynamic (optionally) in standalone mode. Improving DB layer error handling. [नवम्बर 29, 2015]
  • V3.81: Warning about PHP V5.4 requirement on the admin page. [नवम्बर 8, 2015]
  • V3.80: Admin pages in your language using Google translation. [अक्टूबर 22, 2015]
  • V3.73: Renaming the Mobile_Detect class for compatibility. [अक्टूबर 14, 2015]
  • V3.72: व्यवस्थापक पृष्ठ लदान की गति में सुधार. [सितम्बर 30, 2015]
  • V3.71: अपडेट जांच की अनुमति के लिए विकल्प की हत्या. [सितम्बर 26, 2015]
  • V3.70: परिवर्तन nginx और माइक्रोसॉफ्ट सर्वर पर प्लगइन का काम करने के लिए. [सितम्बर 20, 2015]
  • V3.64: टच स्क्रीन उपकरणों पर सुनिश्चित करना प्रयोज्य. [सितम्बर 17, 2015]
  • V3.63: विकल्प Reinstating व्यवस्थापक पृष्ठ लोडिंग के लिए मजबूर करने के लिए, एक कम रंगीन डिफ़ॉल्ट विषय पर चलती. [सितम्बर 14, 2015]
  • V3.62: माइनर refactoring परिवर्तन. [सितम्बर 12, 2015]
  • V3.61: Adding the missing EzPlugin.php.[सितम्बर 9, 2015]
  • V3.60: Removing WP core file loading. [सितम्बर 4, 2015]
  • V3.52: Fixing a minor error in text-wrapping around the bottom ad. [अगस्त 20, 2015]
  • V3.51: Ensuring plugin admin files can be loaded in an iFrame. [अगस्त 19, 2015]
  • V3.50: Compatibility with WordPress 4.3. [अगस्त 10, 2015]
  • V3.42: Fixing the "Database Replace/Insert Error" that affected some servers. [अगस्त 8, 2015]
  • V3.41: Fixing a bug in mobile detection. [अगस्त 1, 2015]
  • V3.40: The plugin now remembers the last used tab. SQL schema change for better compatibility. Fixing a bug that may have caused the plugin not to display ads on some pages/posts. New option to control mid-text ad position in pro version. [जुलाई 30, 2015]
  • V3.35: Minor improvements in setup, plugin active status check and AJAX functions. [जुलाई 26, 2015]
  • V3.34: Minor changes in links. [जून 25, 2015]
  • V3.33: प्रलेखन परिवर्तन केवल. [जून 18, 2015]
  • V3.32: Admin page improvements. [मई 22, 2015]
  • V3.31: व्यवस्थापक पेज अनुकूलता की जांच और सुधार. [मई 12, 2015]
  • V3.30: Compatibility with WordPress 4.2. [अप्रैल 25, 2015]
  • V3.23: Preparing the codebase for the release of AJAX AdSense. [अप्रैल 17, 2015]
  • V3.22: व्यवस्थापक डैशबोर्ड में सुधार. [अप्रैल 14, 2015]
  • V3.21: व्यवस्थापक डैशबोर्ड में सुधार. [अप्रैल 14, 2015]
  • V3.20: Launching a demo site. [अप्रैल 11, 2015]
  • V3.19: More changes in the compatibility check. [अप्रैल 7, 2015]
  • V3.18: कुछ ब्लॉगों पर प्रकट करने के लिए नहीं व्यवस्थापक पृष्ठ का कारण हो सकता है कि एक शैली फिक्सिंग. [अप्रैल 4, 2014]
  • V3.17: अधिक अनुकूलता के चेक. [अप्रैल 2, 2015]
  • V3.16: Minor fixes. [मार्च 27, 2015]
  • V3.15: Fixing a bug that prevented custom fields from working properly. [मार्च 26, 2015]
  • V3.14: Minor bug fix on ad suppression while not in loop. [मार्च 25, 2015]
  • V3.13: Adding error handling for updates. [मार्च 24, 2015]
  • V3.12: Serious bug fix related to multiple passes of the content filter. Introducing a verbosity option. [मार्च 22, 2015]
  • V3.11: मामूली त्रुटि समाधान, and adding diagnostic comments. [मार्च 21, 2015]
  • V3.10: This twitter-bootstrap version of the plugin is now feature-complete. [मार्च 19, 2015]
  • V3.09: Adding information about how to revert to the non-AJAX version of the plugin. [मार्च 16, 2015]
  • V3.08: Documentation and usability enhancements. [मार्च 13, 2015]
  • V3.07: Documentation and usability enhancements. [मार्च 11, 2015]
  • V3.06: More changes for compatibility with PHP5.30. [मार्च 11, 2015]
  • V3.04: लॉगिन की जांच कार्यों में सुधार. Various accumulated fixes. [मार्च 9, 2015]
  • V3.03: Killing anonymous functions for compatibility with PHP versions older than 5.3. [मार्च 8, 2015]
  • V3.02: Changes to the activation validation checks. [मार्च 7, 2015]
  • V3.01: Modifications to the update module. Minor code clean up. [मार्च 5, 2015]
  • V3.00: Complete rewrite of the plugin with a lot more features. Admin page based on the twitter bootstrap framework. [मार्च 3, 2015]
  • V2.50: Compatibility with WP4.1. [जनवरी 8, 2015]
  • V2.40: Renaming the plugin as requested by Google. [नवम्बर 30, 2014]
  • V2.30: प्लगइन सक्रियण पर स्वचालित विकल्प माइग्रेशन. [सितम्बर 26, 2014]
  • V2.22: Minor change to the admin interface. [सितम्बर 9, 2011]
  • V2.21: WP4.0 साथ संगतता. [सितम्बर 8, 2014]
  • V2.20: WP4.0 साथ संगतता. [सितम्बर 7, 2014]
  • V2.12: अद्यतन कर रहा है अनुवाद, मामूली बग फिक्स. [जुलाई 17, 2014]
  • V2.11: Minor bug fix. [मई 8, 2014]
  • V2.10: WP3.9 साथ अंतर्राष्ट्रीयकरण और अनुकूलता. [मई 7, 2014]
  • V2.00: Major changes to the design -- adding a translation interface, getting ready to change options handling. [मार्च 22, 2014]
  • V1.81: Adding options to suppress ads on sticky front page or search pages. [जनवरी 5, 2013]
  • V1.80: वर्डप्रेस v3.8 के लिए संगतता के चेक. Bug fixes in options migration. [दिस. 18, 2013]
  • V1.70: Compatibility checks for WordPress V3.7. [नवम्बर 11, 2013]
  • V1.60: WP3.6 साथ संगतता. [अगस्त 10, 2013]
  • V1.50: Adding an admin page translator. [मई 22, 2013]
  • V1.46: बग सुधार (Fatal error: Call-time pass-by-reference has been removed). [जनवरी 24, 2013]
  • V1.45: बग तय. [दिस. 22, 2012]
  • V1.44: Enforcing the Google policy on the number of ads, and making the pub-id entry flexible. [नवम्बर 4, 2012]
  • V1.43: Minor changes to validate the readme.txt. [अक्टूबर 21, 2012]
  • V1.42: Minor changes to validate the readme.txt. [अक्टूबर 21, 2012]
  • V1.41: Initial public release of the lite version. [अक्टूबर 21, 2012]
  • V1.40: Admin interface modifications. [सितम्बर 30, 2012]
  • V1.31: वर्डप्रेस डिबग मोड से कुछ डिबग नोटिस की देखभाल. [अगस्त 28, 2012]
  • V1.30: Initial public listing at WordPress.org. [जुलाई 18, 2012]
  • V1.20: बग सुधार, सुधार कोडिंग. [सितम्बर 9, 2011]
  • V1.00: आरंभिक रिलीज. [नवम्बर 15, 2010]

पूछे जाने वाले सवाल

मैं कैसे सीएसएस का उपयोग विज्ञापन ब्लॉकों की उपस्थिति को नियंत्रित कर सकते हैं?

सभी <div>s that Ads EZ Plugin for Google AdSense creates have the class attribute adsense. और भी, वे वर्ग की तरह विशेषताएँ adsense-top, adsense-bottom आदि, आप अपने विषय में इन वर्गों के लिए शैली सेट कर सकते हैं style.css उनकी उपस्थिति को नियंत्रित करने के लिए.

मैं विज्ञापन ब्लॉकों प्रत्येक पृष्ठ में स्वरूपित हैं कैसे नियंत्रित कर सकते हैं?

हाँ! In Ads EZ Plugin for Google AdSense, आप अधिक विकल्प हैं [के माध्यम से कस्टम फ़ील्ड्स] व्यक्तिगत पदों / पृष्ठों में विज्ञापन ब्लॉकों को नियंत्रित करने के लिए. जैसे कुंजी के साथ कस्टम फ़ील्ड जोड़ें adsense-top, adsense-middle, adsense-bottom और जैसे मूल्यों के साथ छोड़ा, सही, केंद्र या ऐसा नहीं विज्ञापन ब्लॉकों प्रत्येक पोस्ट या पेज में दिखाने कैसे नियंत्रण करने के लिए. मूल्य "ऐसा नहीं" कि प्रदाता के लिए पद या पृष्ठ के सभी विज्ञापन ब्लॉकों को दबा.

How do I use shortcodes?

In the Pro version of this plugin, you can control the ad placements using the shortcode [adsense] in your blog posts and pages. If you would like to place your ads using shortcodes, please enable it on the Pro page.

डिफ़ॉल्ट रूप से, only those ads specified by the shortcode will be displayed (when shortcodes are enabled). You can specify how the plugin handles shortcode priority using a drop-down menu. You have these choices:

  • Do auto placements if shortcode is missing
  • Do not place any ads if shortcode is missing
  • Always ignore shortcodes and do only auto placement
  • Do not place any ads in posts/pages

The last option effectively disables the plugin for the body of posts and pages, leaving the widgets unaffected.

I don't understand the Pro features. Porn and site block - can't you set those during Asdense ad setup?

What you have in AdSense is an ability to block ads from certain sites. उदाहरण के लिए, if you don't like ads से my site "thulasidas.com", you can block them. What the pro version gives you is the ability to block ads को certain clients. यही है, if you don't want visitors from certain IP addresses see your ads (because they may click on too many of them, getting your AdSense account banned, उदाहरण के लिए), you can with my plugin.

Porn block also is similar -- Google lets you choose non-porn ads (मुझे लगता है कि). What my plugin does is to look at the content of your page, and block ads if it looks like a porn page. (This can happen if a spammer posts a porn kind of comment on your blog, which again may get your AdSense account banned.)

कैसे मैं एक बग रिपोर्ट या एक सवाल पूछना है?

कोई समस्या रिपोर्ट करें, और अपने विचारों और टिप्पणियों को साझा वर्डप्रेस पर प्लगइन मंच पर या मुझसे संपर्क.

आप में एक सवाल है या प्रो संस्करण के बारे में टिप्पणी, WordPress.org पर होस्ट मंच का उपयोग नहीं करते कृपया, लेकिन प्लगइन लेखक से संपर्क हमारे समर्थन पोर्टल का उपयोग.

Can I go back to the previous version of the plugin? I don't like the modern bootstrap/AJAX interface.

You can download the previous version and install it. First deactivate and delete the latest version of the plugin, and then follow the Uploading method under the स्थापना section of this document. The new version uses an completely different options model, and your old options are left intact in your database, so that you can go back anytime.

क्यों मैं प्लगइन फाइलों तक सीधी पहुंच के बारे में कुछ कह रही त्रुटि संदेश मिलता है?

इस प्लगइन व्यवस्थापक इंटरफ़ेस एक शिथिल युग्मित वास्तुकला के साथ बनाया गया है, जिसका मतलब है कि यह केवल कुछ आवश्यक सेवाओं के लिए वर्डप्रेस कोर के साथ सूचना का आदान प्रदान (लॉग इन करें चेक, प्लगइन सक्रियण स्थिति, डेटाबेस का उपयोग आदि). शिथिल युग्मित सिस्टम वे एक दूसरे के बारे में कम मान्यताओं बनाने क्योंकि कसकर एकीकृत लोगों की तुलना में अधिक मजबूत और लचीला हो जाते हैं. मेरे प्लगइन व्यवस्थापक पृष्ठों काफी स्वतंत्र हैं, और वैश्विक गुंजाइश अपवित्र या शैली निर्देशों या जावास्क्रिप्ट कार्यों रिसाव नहीं. इस लक्ष्य को हासिल करने के लिए, वे WordPress व्यवस्थापक अंतरफलक के अंदर iframes में लोड कर रहे हैं.

अपने वेब सर्वर एक iframe में कुछ भी लोड करने के लिए प्लगइन फाइलों तक सीधी पहुंच की जरूरत. कुछ आक्रामक सुरक्षा सेटिंग्स उपयोग इस तरह ब्लॉक, आम तौर पर एक के माध्यम से .htaccess में दायर अपने wp-content या plugins फ़ोल्डरों, यह फ़ाइलों का उपयोग करने में असमर्थता का पता लगाता है, तो इस प्लगइन एक इसी त्रुटि संदेश देता है, यही वजह है (एक के माध्यम से जाँच file_get_contents एक प्लगइन फ़ाइल यूआरएल पर कॉल). लेकिन कुछ सिस्टम पर विशेष रूप से आगे ब्लॉकों लागू file_get_contents या विशिष्ट शैली के साथ iFrames पर (का उपयोग करते हुए mod_securty नियम, उदाहरण के लिए), प्लगइन इस ऑटो का पता लगाने के स्थान पर आ और व्यवस्थापक पृष्ठ के लिए मजबूर करने के लिए एक साधन प्रदान करता है, यही वजह है.

प्लगइन के लिए सीधी पहुँच एक सुरक्षा छेद फ़ाइलें?

यह PHP फाइलों तक सीधी पहुंच की जरूरत है कि केवल अपने वेबसर्वर है कि नोट. इस तरह के उपयोग को रोकने के लिए कारण एक हैकर एक दुर्भावनापूर्ण पीएचपी अपलोड करने में सक्षम हो सकता है (या अन्य निष्पादन स्क्रिप्ट) अपने वेब होस्ट करने के लिए, करने के लिए कहा, तो अपने वेबसर्वर चलेंगे जो. इस तरह की एक चिंता का विषय केवल आप स्पष्ट रूप से अनियंत्रित फाइल अपलोड की अनुमति जहां सिस्टम पर मान्य है. उदाहरण के लिए, किसी को भी अपने मीडिया फ़ोल्डर में किसी भी फाइल को अपलोड कर सकते हैं, और अपने मीडिया फ़ोल्डर सीधी पहुँच और स्क्रिप्ट निष्पादन के खिलाफ सुरक्षित नहीं है, आप संभावित हैकर एक हमले वेक्टर दे दिया है. This plugin has no upload facility, so allowing your webserver to serve the plugin admin files in an iFrame is completely safe, अपने फैसले में.

WP प्लस

WP Plusयह और अन्य plugins स्थापित और उपयोग कर मूल प्रबंधित किया जा सकता है WP-अधिक -- वर्डप्रेस की अगली पीढ़ी, पेशेवर प्लगइन्स और विषयों जो मांग पेशेवर ब्लॉगर के लिए विकसित. तुम एक पेशेवर प्लगइन डेवलपर या एक ब्लॉगर हैं (ब्लॉगिंग या ब्लॉग से संबंधित developement के बाहर एक जीवित करने की उम्मीद है जो एक), इसे बाहर की जाँच करते हैं!
यह भी देखें:& Nbsp; और nbsp;अन्य plugins
आप मेरे प्लगइन प्रयासों की तरह हैं, नीचे अपने Facebook लॉगिन का उपयोग करके एक टिप्पणी छोड़ कृपया.
आप मदद की जरूरत है, उपयोग कृपया हमारे समर्थन पोर्टल बजाय. & Nbsp;ezSupport Portal
[गर्व द्वारा लाया EZ वेतनपाल.]

टिप्पणियां