Google AdSense

Sunset édition
Cette mise à jour du plug-in est la dernière version rendue publique. Nous ne prévoyons pas d'apporter des modifications graves ou ajouter de nouvelles fonctionnalités à partir de maintenant.

Nous ne pouvons pas toujours être en mesure de fournir un soutien rapide pour ce plugin sur les forums WordPress.org. Si vous souhaitez bénéficier d'un soutien professionnel ou des fonctionnalités supplémentaires / personnalisées, envisager d'acheter la Ultra version

Ads EZ Plugin for Google AdSense provides a streamlined interface to deploy Google ads on your blog. You can customize the colors, sizes and placement of the ad blocks and activate them right from the plugin interface.The admin interface uses a highly functional and modern interface based on the twitter bootstrap framework with generous, aide contextuelle sur chaque option.

Live Demo

Google AdSense admin interface is feature-rich, user-friendly and functional. Please visit this fully operational live demo site to see what it can do for you.

Ads EZ Plugin for Google AdSense is a specialized version of Google AdSense Ultra, which lets you manage in basic, standard and expert modes, all in a beautifully designed modern interface.

Traits

  • Affichage riche et options d'alignement.
  • Contrôle du positionnement et de l'affichage des blocs d'annonces dans chaque poste ou la page.
  • Personnalisé l'interface Google avec les sélecteurs de couleurs.
  • Widgets pour votre sidebar.
  • Beautifully designed, fully responsive, intuitive interface.
  • Inline editing and instant saving of your options with AJAX (no more form submit/refresh etc.)
  • Une visite de l'interface pour vous familiariser avec les caractéristiques de plugin et mise en page.
  • aide de Popover pour chaque option dans le plugin.
  • Aptitude à frayer l'interface du plugin en tant qu'entité distincte onglet / fenêtre indépendante de l'interface d'admin WordPress.
  • Base de code robuste et modèles option / d'objets.

Version Pro

Ads EZ Plugin for Google AdSense is the freely distributed version of a premium plugin. La Ultra version vous donne encore plus de fonctionnalités.

  • Coffre-fort Filtre de contenu: Pour vous assurer que vos annonces Google AdSense montrent que sur les pages qui semblent se conformer aux politiques de Google AdSense, qui peut être important car certains commentaires peuvent rendre vos pages incompatibles avec les politiques.
  • Filtre IP: Possibilité de spécifier une liste d'ordinateurs sur lesquels vos annonces ne seront pas affichés, afin d'éviter les clics accidentels sur vos propres annonces -- l'une des principales raisons AdSense vous interdictions. Ces caractéristiques minimiser vos chances d'être banni.
  • Le mode de compatibilité: Pour résoudre le problème de l'insertion de publicité gâcher votre page apparitions lors de l'utilisation des thèmes.
  • Catégorie / poste de contrôle: Capacité à supprimer des annonces sur des catégories spécifiques, les messages et les pages.
  • Soutien Shortcode: Voir les annonces uniquement sur les pages ou les messages que vous voulez, et exactement où vous le souhaitez.
  • Soutien Mobile: Possibilité d'afficher différents ensembles de publicités sur appareils mobiles, ou de supprimer annonces.
  • Extraits: Possibilité d'afficher un nombre configurable de publicités sur Extraits (qui constituent la page d'accueil dans certains thèmes).
  • Ensembles d'options: Plusieurs ensembles d'options peuvent être définies et facilement commutés entre.
  • Suspendre annonces: Possibilité de supprimer temporairement la diffusion des annonces.
  • interface d'administration Thèmes: Schémas de couleurs multiples pour l'interface d'admin.
  • Ad Serving Statistiques: Gardez un œil sur votre annonce servant statistiques pour se assurer que Google ne est pas vous shortchanging. (Module optionnel payant)
  • Basic/Expert Modes: You can choose to operate it in basic or expert modes in addition to the standard mode.

The Ultra version costs $9.45 et peuvent être acheté en ligne avec un lien de téléchargement instantané.

Installation

Searching

La meilleure façon d'installer ce plugin est d'utiliser l'interface admin WordPress. Accédez à votre administrateur tableau de bord, trouver le "Plugins" menu, et cliquez sur "Ajouter un nouveau". Search for this plugin and click on "Installer maintenant" et suivez les instructions de WordPress.

Uploading

Si vous voulez télécharger et installer manuellement, vous pouvez de nouveau utiliser l'interface du tableau de bord WordPress. Commencez par télécharger le fichier zip de plugin sur votre ordinateur local. Ensuite, allez à votre admin tableau de bord, trouver le "Plugins" menu, et cliquez sur "Ajouter un nouveau". Après avoir cliqué sur le "Ajouter un nouveau" élément de menu comme ci-dessus, cliquez sur "Télécharger" (ci-dessous le titre "Installer des plugins" près du sommet). Parcourir pour votre fichier zip téléchargé, télécharger et activer le plugin.

Using Plugin Interface

Further updates (and Pro upgrades and module installations) to the plugin can be done easily from the plugin admin page itself, by clicking on the Updates button on the top right corner.

Pour installer la version professionnelle du plugin, s'il vous plaît deactivage la version Lite (le cas échéant) première. Ensuite, téléchargez le fichier zip que vous télécharger après votre achat en utilisant l'interface d'administration de WordPress indiqué ci-dessous.

[install]

Le plugin est mise à jour également en suivant le même processus, de préférence de la page plugin admin où vous verrez un formulaire de téléchargement de fichier lorsqu'une mise à jour est prête. La première mise à jour pour votre plugin acheté est toujours libre.

Captures d'écran

  1. Annonces EZ Plugin pour Google AdSense "Vue d'ensemble" onglet. & nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 1
  2. How to set the options for Ads EZ Plugin for Google AdSense.  Screenshot [ads-ez-plugin-for-google-adsense] 2
  3. Configuration avancée du plugin. & Nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 3
  4. Options pour soutenir la sécurité, compatibilité, les appareils mobiles et catégorie / après contrôle & nbsp;. & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 4

Changer Connexion

  • V4.20: Compatibility with WP4.8. Sunset edition. [Août 1, 2017]
  • V4.10: Compatibilité avec WP4.6. De nombreux correctifs accumulés et les changements. Libérer la version du coucher du soleil. [Octobre 12, 2016]
  • V4.00: Compatibilité avec WP4.5. [Avril 12, 2016]
  • V3.98: Des améliorations dans l'interface Google Translator. Compatibilité avec installaton multisite de type subdomain. [Février 28, 2016]
  • V3.97: interface et la documentation des changements mineurs. [Février 25, 2016]
  • V3.95: Travailler autour des serveurs qui refusent d'enregistrer le code d'annonce en raison de la balise de script. [Février 18, 2016]
  • V3.94: Restreindre Google Translate ne pas traduire les chaînes modifiables par l'utilisateur. Optimisation de captures d'écran. [Février 7, 2016]
  • V3.94: Assurer les titres de widgets peut être supprimée dans Easy AdSense. [Jan 27, 2016]
  • V3.93: Ajout d'informations de diagnostic sur la page de mise à jour. [Jan 20, 2016]
  • V3.92: Les changements pour rendre le plugin compatible avec les installations multisites. [Jan 14, 2016]
  • V3.91: Ajout d'un dev-friendly comprennent à introduire les paramètres locaux, le cas échéant. [Décembre 30, 2015]
  • V3.90: Compatibilité avec WordPress 4.4. [Décembre 5, 2015]
  • V3.82: Making the admin menu dynamic (optionally) in standalone mode. Améliorer la gestion des erreurs de la couche DB. [Novembre 29, 2015]
  • V3.81: Warning about PHP V5.4 requirement on the admin page. [Novembre 8, 2015]
  • V3.80: Pages Admin dans votre langue à l'aide de la traduction de Google. [Octobre 22, 2015]
  • V3.73: Renommer la classe Mobile_Detect pour la compatibilité. [Octobre 14, 2015]
  • V3.72: Improving the speed of admin page loading. [Septembre 30, 2015]
  • V3.71: Killing the option to allow update checks. [Septembre 26, 2015]
  • V3.70: Changes to make the plugin work on nginx and Microsoft servers. [Septembre 20, 2015]
  • V3.64: Ensuring usability on touch-screen devices. [Septembre 17, 2015]
  • V3.63: Reinstating the option to force the admin page loading, moving to a less colorful default theme. [Septembre 14, 2015]
  • V3.62: Modifications de refactorisation mineurs. [Septembre 12, 2015]
  • V3.61: Ajout du EzPlugin.php manquant.[Septembre 9, 2015]
  • V3.60: WP Retrait fichier de base de chargement. [Septembre 4, 2015]
  • V3.52: Fixing a minor error in text-wrapping around the bottom ad. [Août 20, 2015]
  • V3.51: Assurer fichiers admin plugin peut être chargé dans un iFrame. [Août 19, 2015]
  • V3.50: Compatibilité avec WordPress 4.3. [Août 10, 2015]
  • V3.42: fixation de la "Base de données Remplacer / Insérer erreur" que certains serveurs affectés. [Août 8, 2015]
  • V3.41: La fixation d'un bogue dans détection mobile. [Août 1, 2015]
  • V3.40: Le plugin se souvient maintenant le dernier onglet utilisé. changement de schéma SQL pour une meilleure compatibilité. La fixation d'un bug qui peut avoir causé le plugin de ne pas afficher des annonces sur certaines pages / messages. Nouvelle option pour contrôler la mi-texte position de l'annonce dans la version pro. [Juillet 30, 2015]
  • V3.35: Des améliorations mineures dans la configuration, Plugin vérification de l'état actif et fonctions AJAX. [Juillet 26, 2015]
  • V3.34: Des changements mineurs dans les liens. [Juin 25, 2015]
  • V3.33: Modifications de la documentation que. [Juin 18, 2015]
  • V3.32: Admin page improvements. [Mai 22, 2015]
  • V3.31: Admin page compatibility checks and improvements. [Mai 12, 2015]
  • V3.30: Compatibilité avec WordPress 4.2. [Avril 25, 2015]
  • V3.23: Preparing the codebase for the release of AJAX AdSense. [Avril 17, 2015]
  • V3.22: Improvements in the admin dashboard. [Avril 14, 2015]
  • V3.21: Improvements in the admin dashboard. [Avril 14, 2015]
  • V3.20: Launching a demo site. [Avril 11, 2015]
  • V3.19: More changes in the compatibility check. [Avril 7, 2015]
  • V3.18: Fixing a style that may have caused the admin page not to appear on some blogs. [Avril 4, 2014]
  • V3.17: More compatibility checks. [Avril 2, 2015]
  • V3.16: Corrections mineures. [Comme 27, 2015]
  • V3.15: Fixing a bug that prevented custom fields from working properly. [Comme 26, 2015]
  • V3.14: Minor bug fix on ad suppression while not in loop. [Comme 25, 2015]
  • V3.13: Adding error handling for updates. [Comme 24, 2015]
  • V3.12: Serious bug fix related to multiple passes of the content filter. Introducing a verbosity option. [Comme 22, 2015]
  • V3.11: Correction de bogues mineurs, and adding diagnostic comments. [Comme 21, 2015]
  • V3.10: This twitter-bootstrap version of the plugin is now feature-complete. [Comme 19, 2015]
  • V3.09: Adding information about how to revert to the non-AJAX version of the plugin. [Comme 16, 2015]
  • V3.08: Documentation and usability enhancements. [Comme 13, 2015]
  • V3.07: Documentation and usability enhancements. [Comme 11, 2015]
  • V3.06: More changes for compatibility with PHP5.30. [Comme 11, 2015]
  • V3.04: Des améliorations dans les fonctions connexion de contrôle. Various accumulated fixes. [Comme 9, 2015]
  • V3.03: Killing anonymous functions for compatibility with PHP versions older than 5.3. [Comme 8, 2015]
  • V3.02: Changes to the activation validation checks. [Comme 7, 2015]
  • V3.01: Modifications to the update module. Minor code clean up. [Comme 5, 2015]
  • V3.00: Réécriture complète du plugin avec beaucoup plus de fonctionnalités. page Admin basé sur le cadre bootstrap twitter. [Comme 3, 2015]
  • V2.50: Compatibilité avec WP4.1. [Jan 8, 2015]
  • V2.40: Renommer le plugin comme demandé par Google. [Novembre 30, 2014]
  • V2.30: Migration automatique des options lors de l'activation du plugin. [Septembre 26, 2014]
  • V2.22: Changement mineur apporté à l'interface d'administration. [Septembre 9, 2011]
  • V2.21: Compatibilité avec WP4.0. [Septembre 8, 2014]
  • V2.20: Compatibilité avec WP4.0. [Septembre 7, 2014]
  • V2.12: Mise à jour des traductions, corrections de bugs mineurs. [Juillet 17, 2014]
  • V2.11: Correction d'un bug mineur. [Mai 8, 2014]
  • V2.10: L'internationalisation et la compatibilité avec WP3.9. [Mai 7, 2014]
  • V2.00: Les principales modifications apportées à la conception -- l'ajout d'une interface de traduction, s'apprête à changer la manipulation des options. [Comme 22, 2014]
  • V1.81: Ajout d'options pour supprimer des annonces sur la première page collant ou les pages de recherche. [Jan 5, 2013]
  • V1.80: contrôles de compatibilité pour WordPress V3.8. Correction de bugs dans la migration des options. [Décembre 18, 2013]
  • V1.70: contrôles de compatibilité pour WordPress V3.7. [Novembre 11, 2013]
  • V1.60: Compatibilité avec WP3.6. [Août 10, 2013]
  • V1.50: Adding an admin page translator. [Mai 22, 2013]
  • V1.46: Corrections de bugs (Erreur fatale: Appelez-temps passer par référence a été supprimée). [Jan 24, 2013]
  • V1.45: Correction d'un bug. [Décembre 22, 2012]
  • V1.44: L'application de la politique de Google sur le nombre d'annonces, et faire l'entrée pub-id souple. [Novembre 4, 2012]
  • V1.43: Minor changes to validate the readme.txt. [Octobre 21, 2012]
  • V1.42: Minor changes to validate the readme.txt. [Octobre 21, 2012]
  • V1.41: Diffusion publique initiale de la version Lite. [Octobre 21, 2012]
  • V1.40: modifications de l'interface d'administration. [Septembre 30, 2012]
  • V1.31: Prendre soin de certains avis de débogage à partir du mode de débogage WordPress. [Août 28, 2012]
  • V1.30: Liste publique initiale au WordPress.org. [Juillet 18, 2012]
  • V1.20: Corrections de bugs, améliorations de codage. [Septembre 9, 2011]
  • V1.00: Version initiale. [Novembre 15, 2010]

Foire aux questions

Comment puis-je contrôler l'apparence des blocs d'annonces en utilisant le CSS?

Tous <div>s that Ads EZ Plugin for Google AdSense creates have the class attribute adsense. En outre, ils ont des attributs de classe comme adsense-top, adsense-bottom etc, Vous pouvez définir le style de ces classes dans votre thème style.css à contrôler leur apparence.

Puis-je contrôler la façon dont les blocs d'annonces sont formatés dans chaque page?

Oui! In Ads EZ Plugin for Google AdSense, vous avez plus d'options [par les champs personnalisés] pour contrôler les blocs publicitaires dans les différents articles / pages. Ajouter des champs personnalisés avec des touches comme adsense-top, adsense-middle, adsense-bottom et avec des valeurs comme gauche, droit, centre ou needs a context d'avoir le contrôle la façon dont les blocs d'annonces apparaissent dans chaque poste ou la page. La valeur "needs a context" supprime tous les blocs d'annonces de la poste ou la page pour ce fournisseur.

Comment puis-je utiliser des shortcodes?

Dans la version Pro de ce plugin, vous pouvez contrôler les emplacements d'annonces en utilisant le shortcode [adsense] dans vos messages et de pages de blog. Si vous souhaitez placer vos annonces en utilisant shortcodes, s'il vous plaît activer sur la page Pro.

Par défaut, que ces annonces spécifiés par le shortcode seront affichées (lorsque shortcodes sont activés). Vous pouvez spécifier la façon dont le plugin gère la priorité de shortcode en utilisant un menu déroulant. Vous avez ces choix:

  • Faites des stages d'auto si shortcode est manquant
  • Ne placez pas d'annonces si shortcode est manquant
  • Toujours ignorer shortcodes et faire le placement automatique seulement
  • Ne placez pas d'annonces dans articles / pages

La dernière option désactive le plugin pour le corps des messages et des pages, laissant les widgets ne sont pas touchés.

Je ne comprends pas les caractéristiques Pro. Porn et le site bloc - tu ne peux pas mettre les cours ad configuration Asdense?

Qu'est-ce que vous avez dans AdSense est une capacité à bloquer les annonces de certains sites. Par exemple, si vous n'aimez pas les annonces à partir de mon site "thulasidas.com", vous pouvez les bloquer. Qu'est-ce que la version pro vous donne la possibilité de bloquer les annonces à certains clients. À savoir, si vous ne voulez pas que les visiteurs de certaines adresses IP par vos annonces (car ils peuvent cliquer sur un trop grand nombre d'entre eux, l'obtention de votre compte AdSense interdit, par exemple), vous pouvez avec mon plugin.

bloc de Porn est également similaire -- Google vous permet de choisir annonces non-porno (Je pense). Qu'est-ce que mon plugin fait est de regarder le contenu de votre page, et bloquer les annonces si elle ressemble à une page porno. (Cela peut se produire si un spammeur affiche une sorte de commentaire de porno sur votre blog, qui encore une fois peut obtenir votre compte AdSense interdit.)

Comment puis-je signaler un bogue ou poser une question?

Se il vous plaît signaler tout problème, et de partager vos pensées et vos commentaires le forum du plugin WordPress au Ou Contactez-moi.

Si vous avez une question ou un commentaire à propos de la version Pro, s'il vous plaît ne pas utiliser le forum organisé à WordPress.org, mais contacter l'auteur du plugin en utilisant notre portail de support.

Puis-je revenir à la version précédente du plugin? Je ne aime pas le bootstrap moderne / interface AJAX.

Vous pouvez télécharger le version précédente et l'installer. Première désactiver et supprimer la dernière version du plugin, and then follow the Uploading method under the Installation section de ce document. La nouvelle version utilise un modèle complètement différent d'options, et vos anciennes options sont laissées intactes dans votre base de données, so that you can go back anytime.

Why do I get error message saying something about direct access to plugin files?

This plugin admin interface is designed with a loosely coupled architecture, which means it interacts with the WordPress core only for certain essential services (login check, plugin activation status, database access etc). Loosely coupled systems tend to be more robust and flexible than tightly integrated ones because they make fewer assumptions about each other. My plugin admin pages are fairly independent, and do not pollute the global scope or leak the style directives or JavaScript functions. In order to achieve this, they are loaded in iFrames within the WordPress admin interface.

Your web server needs direct access to the plugin files to load anything in an iFrame. Some aggressive security settings block this kind of access, usually through an .htaccess file in your wp-content ou plugins folders, which is why this plugin gives a corresponding error message if it detects inability to access the files (checked through a file_get_contents call on a plugin file URL). But some systems implement further blocks specifically on file_get_contents or on iFrames with specific styles (aide mod_securty rules, par exemple), which is why the plugin provides a means to override this auto-detection and force the admin page.

Is the direct access to plugin files a security hole?

Note that it is only your own webserver that needs direct access to the PHP files. The reason for preventing such access is that a hacker might be able to upload a malicious PHP (or other executable script) to your web host, which your webserver will run if asked to. Such a concern is valid only on systems where you explicitly permit unchecked file uploads. Par exemple, if anyone can upload any file to your media folder, and your media folder is not protected against direct access and script execution, you have given the potential hacker an attack vector. This plugin has no upload facility, so allowing your webserver to serve the plugin admin files in an iFrame is completely safe, in my judgement.

WP-Plus

WP PlusCeci et d'autres plugins peut être installé et géré de façon transparente à l'aide WP-Plus -- la prochaine génération de WordPress, mis au point pour le blogueur professionnel qui exigent des plugins et des thèmes professionnels. Si vous êtes un développeur de plug-in professionnel ou un blogueur (celui qui espère faire une vie hors des blogs ou developement liés blog-), ne vérifier!
Voir aussi:  Autres plugins
Si vous aimez mes efforts plugin, s'il vous plaît laisser un commentaire en utilisant votre login Facebook ci-dessous.
Si vous avez besoin d'aide, s'il vous plaît utiliser notre portail de support plutôt. & Nbsp;ezSupport Portal
[Fièrement présenté par EZ PayerCopain.]

Commentaires