Google AdSense

Sunset Edition
This update of the plugin is the last publicly released version. We do not expect to make any serious changes or add new features to it from now on.

We may not always be able to provide prompt support for this plugin on the WordPress.org forums. If you would like to have professional support or extra/custom features, considerar la compra de la Ultra versión

Anuncios EZ Plugin para Google AdSense ofrece una interfaz optimizada para desplegar los anuncios de Google en su blog. Puede personalizar los colores, tamaños y la colocación de los bloques de anuncios y activarlos desde el interfaz de complementos interface.The administrador utiliza una interfaz muy funcional y moderno, basado en el marco de arranque Twitter con generosa, ayuda contextual en cada opción única.

Live Demo

Google AdSense admin interface is feature-rich, user-friendly and functional. Please visit this fully operational live demo site to see what it can do for you.

Anuncios EZ Plugin para Google AdSense es una versión especializada de Google AdSense Ultra, que le permite administrar en básica, expertos modos estándar y, todo en una interfaz moderna bellamente diseñado.

Características

  • Rich pantalla y opciones de alineación.
  • El control sobre el posicionamiento y la visualización de bloques de anuncios en cada mensaje o una página.
  • Personalizada interfaz de Google con selectores de color.
  • Aplicaciones para tu barra lateral.
  • Beautifully designed, fully responsive, intuitive interface.
  • Inline editing and instant saving of your options with AJAX (no more form submit/refresh etc.)
  • Un tour interfaz para familiarizarse con las características del plugin y el diseño.
  • Ayuda Popover para cada opción en el plugin.
  • Capacidad para generar la interfaz de complementos como una pestaña / ventana separada independiente de la interfaz de administración de WordPress.
  • Código base robusta y modelos de opción / objeto.

Pro Version

Anuncios EZ Plugin para Google AdSense es la versión libre distribución de un plugin premium. La Ultra versión le da aún más funciones.

  • Segura Filtro: Para asegurarse de que sus anuncios de AdSense de Google muestran únicamente en aquellas páginas que parecen cumplir con las políticas de Google AdSense, que puede ser importante, ya que algunos comentarios pueden hacer que sus páginas sean incompatibles con las políticas.
  • Filtro IP: Capacidad para especificar una lista de equipos en los que no se mostrarán sus anuncios, con el fin de evitar los clics accidentales en sus propios anuncios -- una de las principales razones de AdSense que prohíbe. Estas características minimizar su probabilidad de ser baneado.
  • El modo de compatibilidad: Para resolver el problema de la inserción de anuncios estropear tus páginas apariencias cuando se utiliza algunos temas.
  • Categoría / Puesto de Control: Capacidad para suprimir los anuncios en categorías específicas, entradas y páginas.
  • Soporte Shortcode: Mostrar los anuncios sólo en las páginas o mensajes que desea, y exactamente donde quieras.
  • Soporte Móvil: Posibilidad de mostrar diferentes conjuntos de anuncios en dispositivos móviles, o para suprimir anuncios.
  • Extractos: Posibilidad de mostrar un número configurable de anuncios en Extractos (que constituyen la página de inicio en algunos temas).
  • Conjuntos de opciones: Conjuntos de opciones múltiples pueden ser definidas y fácilmente cambiar entre.
  • Suspender Anuncios: Capacidad para suprimir temporalmente la publicación de anuncios.
  • Temas interfaz de administración: Combinaciones de colores múltiples para la interfaz de administración.
  • Ad Serving Estadísticas: Mantenga un ojo en la publicación de anuncios de estadísticas para asegurarse de que Google no está estafando a usted. (Módulo pagado Opcional)
  • Básico / Modos Experto: Usted puede optar por operar en modos básicos o de expertos, además del modo estándar.

Los costes de versión Ultra $9.45 y puede ser comprado en línea con enlace de descarga instantánea.

Instalación

Búsqueda

La forma más sencilla de instalar este plugin es utilizar la interfaz de administración de WordPress. Vaya a su panel de control de administrador, encontrar el "Plugins" menú, y haga clic en "Crear Nuevo". Búsqueda de este plugin y haga clic en "Instalar ahora" y siga las instrucciones de WordPress.

Carga

Si desea descargar e instalar manualmente, podrá utilizar de nuevo la interfaz de panel de WordPress. Primero descarga el archivo zip plugin para el equipo local. A continuación, vaya a su panel de control de administrador, encontrar el "Plugins" menú, y haga clic en "Crear Nuevo". Después de hacer clic en el "Crear Nuevo" elemento de menú que el anterior, haga clic en "Subir" (debajo del título "Instalar Plugins" cerca de la cima). Busque el archivo zip descargado, subirlo y activar el plugin.

Utilizando Plugin Interface

Otras actualizaciones (y mejoras de Pro e instalaciones de módulos) al plugin se puede hacer fácilmente desde la página de administración propio plugin, haciendo clic en el Actualizaciones botón en la esquina superior derecha.

Para instalar la versión profesional del complemento, por favor deactivage la versión Lite (si alguno) primero. Luego subir el archivo zip que descarga después de su compra mediante la interfaz de administración de WordPress se muestra a continuación.

[install]

El plugin es actualizado también siguiendo el mismo proceso, preferiblemente de la página de administración plug-in, donde se ve una forma de carga de archivos cuando una actualización está lista. La primera actualización de su plugin comprado es siempre libre.

Imágenes

  1. Anuncios EZ Plugin para Google AdSense "Información general" tab. & nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 1
  2. Cómo configurar las opciones de Anuncios EZ Plugin de Google AdSense. & Nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 2
  3. Configuración avanzada del plugin. & Nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 3
  4. Opciones para apoyar a la seguridad, compatibilidad, dispositivos móviles y categoría / control post. & nbsp; & nbsp;Screenshot [ads-ez-plugin-for-google-adsense] 4

Listado de cambios

  • V4.20: Compatibility with WP4.8. Sunset edition. [Agosto 1, 2017]
  • V4.10: Compatibility with WP4.6. Many accumulated fixes and changes. Releasing the sunset version. [Octubre 12, 2016]
  • V4.00: Compatibilidad con WP4.5. [Abril 12, 2016]
  • V3.98: Improvements in the Google Translator interface. Compatibility with multisite installaton of subdomain type. [Febrero 28, 2016]
  • V3.97: Minor interface and documentation changes. [Febrero 25, 2016]
  • V3.95: Work-around for servers that refuse to save ad code because of the script tag. [Febrero 18, 2016]
  • V3.94: Restricting Google Translate not to translate user-editable strings. Optimizing screenshots. [Febrero 7, 2016]
  • V3.94: Garantizar títulos de widget se puede suprimir en Fácil de AdSense. [Ene 27, 2016]
  • V3.93: Adición de la información de diagnóstico en la página de actualización. [Ene 20, 2016]
  • V3.92: Changes to make the plugin compatible with multisite installations. [Ene 14, 2016]
  • V3.91: Adding a dev-friendly include to introduce local settings, si alguno. [Diciembre 30, 2015]
  • V3.90: Compatibilidad con WordPress 4.4. [Diciembre 5, 2015]
  • V3.82: Making the admin menu dynamic (optionally) in standalone mode. Improving DB layer error handling. [Nueva 29, 2015]
  • V3.81: Advertencia sobre PHP requisito V5.4 en la página de administración. [Nueva 8, 2015]
  • V3.80: Admin pages in your language using Google translation. [Octubre 22, 2015]
  • V3.73: Renaming the Mobile_Detect class for compatibility. [Octubre 14, 2015]
  • V3.72: Improving the speed of admin page loading. [Septiembre 30, 2015]
  • V3.71: Killing the option to allow update checks. [Septiembre 26, 2015]
  • V3.70: Changes to make the plugin work on nginx and Microsoft servers. [Septiembre 20, 2015]
  • V3.64: Ensuring usability on touch-screen devices. [Septiembre 17, 2015]
  • V3.63: Reinstating the option to force the admin page loading, moving to a less colorful default theme. [Septiembre 14, 2015]
  • V3.62: Cambios de refactorización menores. [Septiembre 12, 2015]
  • V3.61: Adding the missing EzPlugin.php.[Septiembre 9, 2015]
  • V3.60: Removing WP core file loading. [Septiembre 4, 2015]
  • V3.52: Fixing a minor error in text-wrapping around the bottom ad. [Agosto 20, 2015]
  • V3.51: Ensuring plugin admin files can be loaded in an iFrame. [Agosto 19, 2015]
  • V3.50: Compatibilidad con WordPress 4.3. [Agosto 10, 2015]
  • V3.42: Fixing the "Database Replace/Insert Error" that affected some servers. [Agosto 8, 2015]
  • V3.41: Fixing a bug in mobile detection. [Agosto 1, 2015]
  • V3.40: The plugin now remembers the last used tab. SQL schema change for better compatibility. Fixing a bug that may have caused the plugin not to display ads on some pages/posts. New option to control mid-text ad position in pro version. [Julio 30, 2015]
  • V3.35: Minor improvements in setup, plugin active status check and AJAX functions. [Julio 26, 2015]
  • V3.34: Minor changes in links. [Junio 25, 2015]
  • V3.33: Sólo cambios en la documentación. [Junio 18, 2015]
  • V3.32: Admin page improvements. [Mayo 22, 2015]
  • V3.31: Admin page compatibility checks and improvements. [Mayo 12, 2015]
  • V3.30: Compatibilidad con WordPress 4.2. [Abril 25, 2015]
  • V3.23: Preparing the codebase for the release of AJAX AdSense. [Abril 17, 2015]
  • V3.22: Improvements in the admin dashboard. [Abril 14, 2015]
  • V3.21: Improvements in the admin dashboard. [Abril 14, 2015]
  • V3.20: Launching a demo site. [Abril 11, 2015]
  • V3.19: More changes in the compatibility check. [Abril 7, 2015]
  • V3.18: Fixing a style that may have caused the admin page not to appear on some blogs. [Abril 4, 2014]
  • V3.17: Más pruebas de compatibilidad. [Abril 2, 2015]
  • V3.16: Correcciones menores. [Mar 27, 2015]
  • V3.15: La fijación de un error que impedía que los campos personalizados funcionen correctamente. [Mar 26, 2015]
  • V3.14: Corrección de errores de menor importancia en la supresión del anuncio mientras no en bucle. [Mar 25, 2015]
  • V3.13: Adición de control de errores para las actualizaciones. [Mar 24, 2015]
  • V3.12: Corrección de errores graves relacionados con múltiples pasadas del filtro de contenidos. La introducción de una opción de verbosidad. [Mar 22, 2015]
  • V3.11: Soluciones de errores leves, y la adición de comentarios de diagnóstico. [Mar 21, 2015]
  • La V3.10: Ahora Esta versión-twitter arranque del plugin es característica-completo. [Mar 19, 2015]
  • V3.09: Agregar información acerca de cómo volver a la versión no-AJAX del plugin. [Mar 16, 2015]
  • V3.08: Mejoras en la documentación y usabilidad. [Mar 13, 2015]
  • V3.07: Mejoras en la documentación y usabilidad. [Mar 11, 2015]
  • V3.06: Más cambios para la compatibilidad con PHP5.30. [Mar 11, 2015]
  • V3.04: Las mejoras en las funciones de comprobación de inicio de sesión. Varias correcciones acumulados. [Mar 9, 2015]
  • V3.03: Matar funciones anónimas para la compatibilidad con versiones anteriores a PHP 5.3. [Mar 8, 2015]
  • V3.02: Los cambios en los controles de validación de activación. [Mar 7, 2015]
  • V3.01: Modifications to the update module. Minor code clean up. [Mar 5, 2015]
  • V3.00: Reescritura completa del plugin con muchas más características. Página de administración basado en el marco de arranque Twitter. [Mar 3, 2015]
  • V2.50: Compatibilidad con WP4.1. [Ene 8, 2015]
  • V2.40: Cambiar el nombre del plug-in a lo solicitado por Google. [Nueva 30, 2014]
  • V2.30: Opciones de migración automática al activarse el plugin. [Septiembre 26, 2014]
  • V2.22: Modificación de importancia menor a la interfaz de administración. [Septiembre 9, 2011]
  • V2.21: Compatibilidad con WP4.0. [Septiembre 8, 2014]
  • V2.20: Compatibilidad con WP4.0. [Septiembre 7, 2014]
  • V2.12: Actualización de traducciones, correcciones de errores menores. [Julio 17, 2014]
  • V2.11: Corrección de errores menores. [Mayo 8, 2014]
  • V2.10: La internacionalización y la compatibilidad con WP3.9. [Mayo 7, 2014]
  • V2.00: Los principales cambios en el diseño -- la adición de un interfaz de traducción, a punto de cambiar el manejo opciones. [Mar 22, 2014]
  • V1.81: Adición de opciones para suprimir los anuncios en la página frontal pegajoso o páginas de búsqueda. [Ene 5, 2013]
  • V1.80: Comprobaciones de compatibilidad para WordPress V3.8. Corrección de errores en las opciones de migración. [Diciembre 18, 2013]
  • V1.70: Comprobaciones de compatibilidad para WordPress V3.7. [Nueva 11, 2013]
  • V1.60: Compatibilidad con WP3.6. [Agosto 10, 2013]
  • V1.50: Adding an admin page translator. [Mayo 22, 2013]
  • V1.46: Corrección de errores (Fatal error: Call-tiempo pase por referencia se ha eliminado). [Ene 24, 2013]
  • V1.45: Corrección de errores. [Diciembre 22, 2012]
  • V1.44: Hacer cumplir la política de Google sobre el número de anuncios, y hacer la entrada pub-Identificación flexibles. [Nueva 4, 2012]
  • V1.43: Minor changes to validate the readme.txt. [Octubre 21, 2012]
  • V1.42: Minor changes to validate the readme.txt. [Octubre 21, 2012]
  • V1.41: Versión pública inicial de la versión lite. [Octubre 21, 2012]
  • V1.40: Modificaciones de la interfaz de administración. [Septiembre 30, 2012]
  • V1.31: El cuidado de algunos avisos de depuración en modo de depuración WordPress. [Agosto 28, 2012]
  • V1.30: La oferta pública inicial en WordPress.org. [Julio 18, 2012]
  • V1.20: Corrección de errores, mejoras de codificación. [Septiembre 9, 2011]
  • V1.00: Versión inicial. [Nueva 15, 2010]

Preguntas más frecuentes

¿Cómo puedo controlar la aparición de los bloques de anuncios que utilizan CSS?

Todos <div>s that Ads EZ Plugin for Google AdSense creates have the class attribute adsense. Además, que tienen los atributos de clase como adsense-top, adsense-bottom etc., Puede configurar el estilo de estas clases en su tema style.css para controlar su apariencia.

¿Puedo controlar cómo se formatean los bloques de anuncios en cada página?

Sí! In Ads EZ Plugin for Google AdSense, usted tiene más opciones [a través campos personalizados] para controlar los bloques de anuncios en mensajes / páginas individuales. Añadir campos personalizados con claves como adsense-top, adsense-middle, adsense-bottom y con valores como izquierda, derecho, centro o no tener el control de cómo los bloques de anuncios se muestran en cada post o página. El valor "no" suprime todos los bloques de anuncios en el correo o la página para ese proveedor.

¿Cómo puedo utilizar códigos cortos?

In the Pro version of this plugin, you can control the ad placements using the shortcode [adsense] en sus blogs y páginas. If you would like to place your ads using shortcodes, please enable it on the Pro page.

Por defecto, sólo se mostrarán los anuncios especificados por el shortcode (when shortcodes are enabled). You can specify how the plugin handles shortcode priority using a drop-down menu. You have these choices:

  • Do auto placements if shortcode is missing
  • Do not place any ads if shortcode is missing
  • Always ignore shortcodes and do only auto placement
  • Do not place any ads in posts/pages

The last option effectively disables the plugin for the body of posts and pages, dejando a los widgets de no afectados.

No entiendo las características Pro. Porno y sitio de bloque - no se puede establecer los anuncios durante la configuración Asdense?

Lo que tienes en AdSense es una capacidad de bloquear los anuncios de determinados sitios. Por ejemplo, si no te gustan anuncios desde mi sitio "thulasidas.com", puede bloquearlas. Lo que la versión Pro te da es la capacidad de bloquear los anuncios a ciertos clientes. Es decir, si no desea que los visitantes de ciertas direcciones IP ver sus anuncios (, ya que pueden hacer clic en demasiados de ellos, consiguiendo su cuenta de AdSense prohibió, por ejemplo), usted puede con mi complemento.

Bloque porno también similar -- Google le permite elegir los anuncios no porno (Yo creo que). Lo que mi plugin no es buscar en el contenido de su página, y bloquear anuncios si se ve como una página porno. (Esto puede ocurrir si un spammer publica una especie porno de comentario en su blog, que a su vez puede obtener su cuenta de AdSense prohibido.)

¿Cómo puedo informar de un bug o hacer una pregunta?

Por favor, informe de cualquier problema, y compartir sus pensamientos y comentarios en el foro plugin de WordPress en O ponerse en contacto conmigo.

Si usted tiene alguna pregunta o comentario acerca de la versión Pro, por favor no utilice el foro organizado en WordPress.org, pero en contacto con el autor del plugin usando nuestro portal de soporte.

¿Puedo volver a la versión anterior del plugin? No me gusta el sistema de arranque moderno / interfaz AJAX.

Puede descargar el versión anterior e instalarlo. Primero desactivar y eliminar la última versión del plugin, y luego seguir el Carga bajo el método Instalación sección de este documento. La nueva versión utiliza un modelo de opciones completamente diferente, y vuestros ancianos opciones se dejan intactos en su base de datos, para que pueda volver en cualquier momento.

Why do I get error message saying something about direct access to plugin files?

This plugin admin interface is designed with a loosely coupled architecture, which means it interacts with the WordPress core only for certain essential services (login check, plugin activation status, database access etc). Loosely coupled systems tend to be more robust and flexible than tightly integrated ones because they make fewer assumptions about each other. My plugin admin pages are fairly independent, and do not pollute the global scope or leak the style directives or JavaScript functions. In order to achieve this, they are loaded in iFrames within the WordPress admin interface.

Your web server needs direct access to the plugin files to load anything in an iFrame. Some aggressive security settings block this kind of access, usually through an .htaccess file in your wp-content o plugins folders, which is why this plugin gives a corresponding error message if it detects inability to access the files (checked through a file_get_contents call on a plugin file URL). But some systems implement further blocks specifically on file_get_contents or on iFrames with specific styles (utilizando mod_securty rules, por ejemplo), which is why the plugin provides a means to override this auto-detection and force the admin page.

Is the direct access to plugin files a security hole?

Note that it is only your own webserver that needs direct access to the PHP files. The reason for preventing such access is that a hacker might be able to upload a malicious PHP (or other executable script) to your web host, which your webserver will run if asked to. Such a concern is valid only on systems where you explicitly permit unchecked file uploads. Por ejemplo, if anyone can upload any file to your media folder, and your media folder is not protected against direct access and script execution, you have given the potential hacker an attack vector. This plugin has no upload facility, so allowing your webserver to serve the plugin admin files in an iFrame is completely safe, in my judgement.

WP-Plus

WP PlusEste y otros plugins puede ser instalado y manejado sin problemas utilizando WP-Más -- la próxima generación de WordPress, desarrollado para el blogger profesional que demandan profesionales plugins y temas. Si usted es un desarrollador de plug-in profesional o un blogger (quien espera hacer una vida fuera de los blogs o Desarrollos relacionados blog-), no verificarlo!
Vea también:& Nbsp; & nbsp;Otros plugins
Si te gustan mis esfuerzos de plugin, por favor deje un comentario utilizando su usuario de Facebook por debajo de.
Si necesita ayuda, aconsejamos probar nuestro portal de soporte lugar. & Nbsp;ezSupport Portal
[Orgullosamente traído a usted por EZ PresteCamarada.]

Comentarios