Easy Translator

Easy Translator is a plugin to translate your blog posts and pages. Esso fornisce un widget personalizzabile per consentire la traduzione automatica (da Google o Microsoft).

Easy Translator also provides a tool for plugin authors and translators. This tool picks up translatable strings (in _[_e]() funzioni) e loro e le loro traduzioni esistenti presenta (dall'oggetto MO del testo-dominio corrente, se loaded) in una forma modificabile utente. Può generare un file PO valido che può essere inviato via email all'autore del filtro.

Il Pro Version adds the following features:

  1. Color-pickers for the blog post translation widget, to customize and match your colors with your theme.
  2. Machine translation help to seed your plugin translation efforts. Questo è, per ogni stringa traducibile trovato, vi darà una traduzione, come fornito da Google, che è possibile modificare e perfetto.
  3. Auto identification of the text-domain used by the plugin being translated.
  4. Email support so that your translators can send the PO file directly from the its window, razionalizzare il loro lavoro.

Se sei un autore plug interessato a internazionalizzare i plugin, si consiglia di chiedere i vostri potenziali traduttori installare Easy Translator per renderlo un gioco da ragazzi per darvi traduzioni. Se si desidera pulire il vostro internazionalizzazione, si potranno apprezzare Easy Translator perché fa una corrispondente stringa fuzzy per evidenziare eventuali ripetizioni e conflitti tra stringhe chiave.

Installazione

Ricerca

Il modo più semplice per installare questo plugin è quello di utilizzare l'interfaccia di WordPress Admin. Vai al tuo dashboard di amministrazione, trovare la "Plugin" menu, e fare clic su "Aggiungi nuovo". Cerca questo plugin e cliccare su "Installa adesso" e seguire le istruzioni WordPress.

Caricamento

Se si desidera scaricare e installare manualmente, è possibile ancora utilizzare l'interfaccia dashboard di WordPress. Prima scaricare il file zip plugin per il vostro computer locale. Poi vai al tuo dashboard di amministrazione, trovare la "Plugin" menu, e fare clic su "Aggiungi nuovo". Dopo aver cliccato sul "Aggiungi nuovo" voce di menu come sopra, fai clic su "Carica" (sotto il titolo "Installa Plugin" vicino alla parte superiore). Sfoglia per il file zip scaricato, caricarlo e attivare il plugin.

FTP

  1. Carica il Easy Translator plugin (l'intera cartella easy-traduttore) nella directory '/ wp-content / plugins /'.
  2. Attivare il plugin tramite il menu 'Plugins' in WordPress.
  3. Vai a Strumenti - & gt; Easy Translator usarlo.

Per installare la versione professionale del plugin, si prega di deactivage la versione Lite (eventuali) primo. Poi caricare il file zip che si scaricare dopo l'acquisto utilizzando l'interfaccia di amministrazione di WordPress mostrato di seguito.

[install]

Il plugin è aggiornato anche seguendo la stessa procedura, preferibilmente dalla pagina dei plugin di amministrazione, dove vedrete una forma di file-upload quando un aggiornamento è pronto. Il primo aggiornamento per il vostro plugin acquistato è sempre gratuito.

Screenshots

  1. Blog page translation - Google widget  Screenshot [easy-translator] 1
  2. Blog page translation - Microsoft widget  Screenshot [easy-translator] 2
  3. Widget customization  Screenshot [easy-translator] 3
  4. How to use the plugin translator - L'Editor & nbsp; & nbsp;Screenshot [easy-translator] 4
  5. The POT File Viewer in the plugin translator.  Screenshot [easy-translator] 5

Change Log

  • V4.90: Compatibilità con WP4.8,,en,edizione Sunset,,en. Sunset edition. [Agosto 1, 2017]
  • V4.80: Compatibilità con WordPress 4.5. [Maggio 12, 2015]
  • V4.71: Interfaccia e documentazione modifiche minori. [Febbraio 25, 2016]
  • V4.70: Deprecando interfaccia di traduzione a favore di traduzione di Google. [Febbraio 23, 2016]
  • V4.60: Compatibilità con WordPress 4.4. [Dicembre 5, 2015]
  • V4.53: Modifiche di refactoring. [Novembre 7, 2015]
  • V4.52: Enhancements in the admin interface. [Ottobre 17, 2015]
  • V4.51: Modifiche alla documentazione. [Settembre 13, 2015]
  • V4.50: Adding a settings page with detailed help on the plugin. Compatibilità con WordPress 4.3. [Agosto 10, 2015]
  • V4.40: Compatibilità con WordPress 4.2. [Aprile 25, 2015]
  • V4:30: Compatibilità con WP4.1. [Jan 8, 2015]
  • V4.21: Modifica minore all'interfaccia di amministrazione. [Settembre 9, 2011]
  • V4.20: Correzioni di bug, compatibilità con WP4.0. [Settembre 8, 2014]
  • V4.10: Modifiche di refactoring accumulati. [Maggio 7, 2014]
  • V4.03: Compatibilità con WordPress V3.9. [Aprile 18, 2014]
  • V4.02: Ulteriori correzioni minori per sopprimere gli avvisi PHP. [Come 29, 2014]
  • V4.01: Bug fix nel widget codice javascript. [Come 29, 2014]
  • V4.00: La revisione completa del progetto. [Come 29, 2014]
  • V3.31: Modifiche di refactoring minori. [Come 24, 2014]
  • V3.30: Compatibilità con WP3.8. Modifiche alla documentazione. [Dicembre 19, 2013]
  • V3.20: Compatibilità con WP3.7. Some minor documentation changes. [Novembre 9, 2013]
  • V3.10: Compatibilità con WP3.6. Alcuni suggerimenti aggiuntivi per aiutare l'utente. [Agosto 15, 2013]
  • V3.01: Solo le modifiche Documentazione. [Maggio 21, 2013]
  • V3.00: Importante aggiornamento di blog Traduzione di pagine così come Google translate a seminare traduzione Plugin. [Maggio 20, 2013]
  • V2.23: Inizializzazione di sessione corretta. [Come 30, 2013]
  • V2.22: L'uso corretto delle variabili di sessione. [Febbraio 18, 2013]
  • V2.21: Correzioni in aggiornamento plug-. [Ottobre 17, 2012]
  • V2.20: Rotolando in-app versione di aggiornamento. [Settembre 30, 2012]
  • V2.13: Inizializzazione di sessione corretta. [Come 30, 2013]
  • V2.12: L'uso corretto delle variabili di sessione. [Febbraio 18, 2013]
  • V2.11: Correzioni di bug (Fatal error: Call-tempo pass-by-reference è stata rimossa). [Jan 27, 2013]
  • V2.10: Including a support link on the admin page. [Settembre 30, 2012]
  • V2.06: Prendersi cura di alcuni avvisi di debug da WordPress modalità di debug. [Agosto 28, 2012]
  • V2.05: Piccole modifiche alla pagina di amministrazione. [Luglio 18, 2012]
  • V2.04: Prendersi cura di magic_quotes_gpc in PHP. [Maggio 18, 2012]
  • V2.03: Renaming the plugin to drop the word Lite. [Maggio 11, 2012]
  • V2.02: Modifica la ricerca di file php per ricorsive. [Come 20, 2012]
  • V2.01: Aggiunta una nuova funzionalità per creare un nuovo file MO (piuttosto che la modifica di uno esistente). [Come 19, 2012]
  • V2.00: Rilasciare una versione Lite e Pro. [Come 6, 2012]
  • V1.01: Correzione di alcuni bug minori (un) Autore e-mail (del plugin essere tradotto è stato impostato per l'autore di questo plugin. (b) Il nome del plugin è stato impostato su Facile AdSense (Grazie, Sub!). (c) Alcune correzioni sono necessarie per sfuggire le virgolette e le interruzioni di riga in locali diverse dall'inglese. Li includerà nella prossima release. (Difficile da testare perché il mio locale è en_US).
  • V1.00: Versione iniziale. [Luglio 21, 2009]

Domande frequenti

I installed the plugin. Nothing happens. Where is the translator?

Please go to Appearance -> Widgets, drag and drop the Easy Translator widget to the sidebar of your choice. Select Microsoft (default) or Google and save. You will find the translator widget on your sidebar.

La versione Pro dovrebbe farmi personalizzare i colori dei widget traduzione. Come?

Per favore, vai a Aspetto - & gt; Widget e aggiungere / modificare i widget di traduzione. Vedrete i selettori colore lì.

Sembra buono, ma non funziona!

Easy Translator è un programma abbastanza complicata. Se si trova un bug o qualcosa che non funziona come previsto, si prega di non tenerlo a youself. Si prega di postare in il forum o email me. Mi piacerebbe davvero farlo funzionare perfettamente.

Questo plugin è in conflitto con altri plugin. Cosa fare adesso?

Easy Translator usa il PHP "super-global" variabili ($_SESSION[]) per contenere varie stringhe e impostazioni tra le vostre visite in modo che il lavoro di traduzione non è accidentalmente cancellati. Spero di aver attuato in modo sicuro. Ma, come ogni sviluppatore ti dirà, non c'è nulla di sicuro su come utilizzare globali. Se trovate qualcosa che non va, Sarei grato se poteste farmi sapere. Si prega di postare in il forum o contatto con me.

Se avete domande o commenti sulla versione Pro, si prega di non utilizzare il forum ospitato a WordPress.org, ma contattare l'autore plug-in utilizzando il nostro portale di supporto.

I file PO creati generano errori quando corro msgfmt sopra. Quali sono questi errori?

Il plugin ha un problema noto con le virgolette all'interno di stringhe. Alcuni dei marchi citazioni non ottenere sfuggito con una barra rovesciata. Penso che questo problema è specifico delle impostazioni internazionali, e non so come risolverlo. Se avete idee, Per favore mi faccia sapere. La soluzione è quella di modificare i file PO generati con un editor di testo e andare alle linee che ti danno gli errori in msgfmt. È molto probabile trovare alcune citazioni escape che si dovrebbe anteporre una barra rovesciata per. Si deve poi passare attraverso msgfmt senza errori. Un altro problema noto è che in alcune zone, il \n personaggio nelle prime righe appaiono come n -- ancora una volta in modo specifico, locale.

Come faccio a farlo tradurre le mie pagine del blog / post?

Per attivare la pagina del blog / traduzione postale, trovare il widget di Easy Translator (sotto l'apparenza - & gt; Menu Widget sulla vostra pagina di amministrazione di WordPress) e rilasciarlo su una barra laterale. Se si dispone della versione Pro del plugin, è possibile modificare i colori del widget per abbinare il vostro tema.

WP-Plus

WP PlusQuesto e altri plugin può essere installato e gestito senza problemi con WP-Di più -- la prossima generazione di WordPress, sviluppato per il blogger professionista che richiedono plugin professionali e temi. Se sei uno sviluppatore del plugin professionale o un blogger (uno che spera di fare una vita fuori di blogging o di sviluppo blog correlati), fare il check-out!
Vedere anche:& Nbsp; & nbsp;Altri plugin
Se ti piacciono i miei sforzi dei plugin, si prega di lasciare un commento con il vostro login di Facebook qui sotto.
Se hai bisogno di aiuto, si prega di utilizzare il nostro portale di assistenza invece. & Nbsp;ezSupport Portal
[Orgogliosamente portato a voi da EZ PagareAmico.]

Commenti