Facile annunci

Facile annunci fornisce un'interfaccia unificata e intuitiva per gestire più fornitori di annunci sul tuo blog. Attualmente sono supportati Chitika, BidVertiser, Clicksor, e, naturalmente, AdSense. L'elenco dei fornitori di annunci sarà ampliato in seguito a richiesta.

AdSense ti ha scaricato? Non essere il cuore spezzato; ci sono altri pesci nel mare. Si possono trovare la felicità con BidVertiser, Chitika or Clicksor. Usa Facile annunci, e potresti essere fortunato!

Si noti che questo plugin richiede PHPv5.3 . Se non funziona sul vostro host web, perche Facile AdSense Lite o Facile AdSense Pro.

Lineamenti

  1. Interfaccia a schede e intuitiva per molteplici operatori di annunci (AdSense, Chitika etc.).
  2. Visualizzazione Rich e opzioni di allineamento.
  3. Codebase robusto per estendere a più fornitori di annunci.
  4. Controllo sul posizionamento e la visualizzazione dei blocchi di annunci in ogni post o pagina.
  5. Interfaccia di configurazione semplice -- nothing more than entering your provider id for AdSense or Chitika, e con delle impostazioni predefinite per le poche opzioni presenti, tutti con istruzioni chiare.
  6. Specialized widgets for AdSense and Chitika, and common widget interface for the rest.
  7. Available in your own language using machine translation curtsey of Google and Microsoft.

Se si desidera utilizzare solo AdSense, si dovrebbe prendere in considerazione la mia vera e propria, ricco di funzionalità plug-in Facile AdSense.

Pro Version

Facile annunci è la versione distribuito gratuitamente di un plugin premio. Il Pro version ti dà ancora più funzionalità.

  1. Nella versione Pro si dispone di un Admin (Pannello di controllo) scheda con:
    • Option to selectively activate or deactivate various ad providers in the Admin Linguetta, so that you can have only AdSense, or only Chitika, if you so choose.
    • Maggiori informazioni sulle posizioni degli annunci e slot (come un'immagine nel Admin Linguetta).
    • Opzione per impostare il numero di spazi pubblicitari per posizione.
    • Nuovi comandi (nel Admin Linguetta) a Ripristina tutte le opzioni, Goccia Tutte le opzioni o Migrazione Opzioni a una nuova versione del plugin.
  2. Un filtro per garantire che la pubblicazione degli annunci solo sulle pagine che sembrano rispettare con Google AdSense (e altro fornitore comuni) politiche, che può essere importante in quanto alcuni commenti possono rendere le tue pagine non coerenti con tali politiche.
  3. Inoltre, consente di specificare un elenco di computer in cui non verranno mostrati i tuoi annunci, al fine di evitare i clic accidentali sui propri annunci -- uno dei principali motivi AdSense vieta.
  4. Anche nelle opere per la versione Pro è una modalità di compatibilità, che risolve il problema dell'inserimento dell'annuncio rovinare le vostre apparenze pagine quando si utilizza alcuni temi.

I costi versione Pro $8.95 e può essere acquistato on-line con collegamento immediato di download.

Progetti per il futuro

Vorrei sapere da voi se avete richieste o commenti funzionalità.

  1. Rotazione degli annunci: Mi impegno a fornire i mezzi per ruotare gli annunci tra i vari fornitori con frequenza definita dall'utente.
  2. Altri fornitori: Questo plugin è stato progettato con l'estensibilità in mente. Terrò l'aggiunta di più fornitori di annunci, o anche lasciare che gli utenti finali aggiungerli.
  3. Competenza Livello: Ho intenzione di introdurre livelli di competenza (Facile, Schede Advanced ed Expert) nella scheda per ogni fornitore annuncio.
  4. Numero massimo di blocchi di annunci: Dal momento che alcuni provider è necessario limitare il numero di blocchi di annunci a qualche soffitto policy-driven, Io esporrò che l'opzione per voi. Inoltre, per essere personalizzato è il numero di annunci per fessura. In questa versione iniziale, ci sono tre slot (top, centro e in basso), ciascuno dei quali può assumere due blocchi di annunci. In una versione futura, avrete molto di più opzioni di personalizzazione.
  5. Internazionalizzazione: Le versioni future forniranno file MO / PO per l'internazionalizzazione.
  6. Documentazione: As this plugin may have an overwhelming set of options and features, I will try to write a comprehensive help system for it.

Installazione

Ricerca

Il modo più semplice per installare questo plugin è quello di utilizzare l'interfaccia di WordPress Admin. Vai al tuo dashboard di amministrazione, trovare la "Plugin" menu, e fare clic su "Aggiungi nuovo". Cerca questo plugin e cliccare su "Installa adesso" e seguire le istruzioni WordPress.

Caricamento

Se si desidera scaricare e installare manualmente, è possibile ancora utilizzare l'interfaccia dashboard di WordPress. Prima scaricare il file zip plugin per il vostro computer locale. Poi vai al tuo dashboard di amministrazione, trovare la "Plugin" menu, e fare clic su "Aggiungi nuovo". Dopo aver cliccato sul "Aggiungi nuovo" voce di menu come sopra, fai clic su "Carica" (sotto il titolo "Installa Plugin" vicino alla parte superiore). Sfoglia per il file zip scaricato, caricarlo e attivare il plugin.

FTP

  1. Carica il Facile annunci plugin (the whole easy-ads-lite folder) nella directory '/ wp-content / plugins /'.
  2. Attivare il plugin tramite il menu 'Plugins' in WordPress.
  3. Vai a Impostazioni - & gt; Facile annunci e inserire i propri codici e le opzioni di annunci.

Per installare la versione professionale del plugin, si prega di deactivage la versione Lite (eventuali) primo. Poi caricare il file zip che si scaricare dopo l'acquisto utilizzando l'interfaccia di amministrazione di WordPress mostrato di seguito.

[install]

Il plugin è aggiornato anche seguendo la stessa procedura, preferibilmente dalla pagina dei plugin di amministrazione, dove vedrete una forma di file-upload quando un aggiornamento è pronto. Il primo aggiornamento per il vostro plugin acquistato è sempre gratuito.

Screenshots

  1. Facile annunci "Panoramica" Scheda & nbsp;. & nbsp;Screenshot [easy-ads] 1
  2. Admin tab showing ad slot locations.  Screenshot [easy-ads] 2
  3. Pro Featires.  Screenshot [easy-ads] 3
  4. How to set the options for Google AdSense.  Screenshot [easy-ads] 4
  5. Come impostare le opzioni per Chitika. & Nbsp; & nbsp;Screenshot [easy-ads] 5

Change Log

  • V4.20: Compatibilità con WP4.8,,en,edizione Sunset,,en. Sunset edition. [Agosto 1, 2017]
  • V4.10: Compatibilità con WordPress 4.5. [Maggio 12, 2015]
  • V4.00: Deprecando interfaccia di traduzione a favore di traduzione di Google. [Febbraio 23, 2016]
  • V3.90: Compatibilità con WordPress 4.4. [Dicembre 5, 2015]
  • V3.83: Modifiche di refactoring. [Novembre 7, 2015]
  • V3.82: Enhancements in the admin interface. [Ottobre 17, 2015]
  • V3.81: Modifiche alla documentazione. [Settembre 13, 2015]
  • V3.80: Major changes to fix HTML5 validation errors. [Settembre 10, 2015]
  • V3.70: Compatibilità con WordPress 4.3. [Agosto 10, 2015]
  • V3.60: Compatibilità con WordPress 4.2. [Aprile 25, 2015]
  • V3.50: Refactoring and documentation changes. [Aprile 2, 2015]
  • V3.40: Compatibilità con WP4.1. [Jan 8, 2015]
  • V3.30: Migrazione opzioni automatico al momento dell'attivazione plug. [Settembre 26, 2014]
  • V3.21: Modifica minore all'interfaccia di amministrazione. [Settembre 9, 2011]
  • V3.20: Compatibilità con WP4.0. [Settembre 6, 2014]
  • V3.12: Traduzioni Aggiornamento, correzioni di bug minori. [Luglio 17, 2014]
  • V3.11: Minor bug fix. [Maggio 8, 2014]
  • V3.10: Internazionalizzazione e la compatibilità con WP3.9. [Maggio 7, 2014]
  • V3.00: Le principali modifiche al disegno -- l'aggiunta di una interfaccia di traduzione, sempre pronto a modificare le opzioni di trattamento. [Come 22, 2014]
  • V2.71: Aggiunta di opzioni per sopprimere annunci su appiccicoso prima pagina o pagine di ricerca. [Jan 5, 2014]
  • V2.70: Controlli di compatibilità per WordPress V3.8. Correzioni di bug nella migrazione opzioni. [Dicembre 18, 2013]
  • V2.60: Controlli di compatibilità per WordPress V3.7. [Novembre 11, 2013]
  • V2.50: Compatibilità con WP3.6. [Agosto 12, 2013]
  • V2.40: Aggiunta di un traduttore pagina di amministrazione. [Maggio 17, 2013]
  • V2.32: Correzioni di bug (Fatal error: Call-tempo pass-by-reference è stata rimossa). [Jan 24, 2013]
  • V2.31: Bug fix. [Dicembre 22, 2012]
  • V2.30: Far rispettare la politica di Google sul numero di annunci, e facendo la voce pub-id flessibile. [Novembre 4, 2012]
  • V2.20: Modifiche di interfaccia Admin. [Settembre 27, 2012]
  • V2.10: Più correzioni di bug minori nella gestione widget e per prendersi cura di alcuni avvisi di debug da WordPress modalità di debug. [Agosto 31, 2012]
  • V2.09: Prendersi cura di alcuni avvisi di debug da WordPress modalità di debug. [Agosto 27, 2012]
  • V2.08: Adding more ad sizes. [Agosto 12, 2012]
  • V2.07: Piccole modifiche alla pagina di amministrazione. [Luglio 18, 2012]
  • V2.06: Testing compatibility with WP 3.4. [Luglio 11, 2012]
  • V2.05: Correzioni di bug. [Maggio 25, 2012]
  • V2.04: Correzioni di bug. [Maggio 18. 2012]
  • V2.03: Renaming the plugin to drop the word Lite. [Maggio 11, 2012]
  • V2.02: Rilassante la versione di PHP richiesta per 5.0 [Aprile 20, 2012]
  • V2.01: Fixing the PHP version checker. [Aprile 19, 2012]
  • V2.00: Prima versione Easy Ads Lite. [Aprile 16, 2012]
  • V1.31: Documentazione e admin pagine display cambia. Non critico. [Agosto 30, 2011]
  • V1.30: Scheda Chitika rispecchia la personalizzazione di annunci come in Chitika.
  • V1.20: Mini-tabs e widget. Tornando a semplici schede CSS. Le opzioni sono di versione nel DB ora. [Novembre 12 2010]
  • V1.10: Schermo specializzata per Chitika. Diverso realizzazione di schede JS (utilizzando YETII). [Ottobre 25 2010]
  • V1.05: Altri miglioramenti all'interfaccia utente e tecnici (preparazione di riutilizzare ezAPI.php per altri plugin) . Il passaggio a Chitika per annunci predefiniti e condivisi. [Ottobre 3, 2010]
  • V1.04: Gestione Graceful di PHP4, il miglioramento della interfaccia di amministrazione. [Settembre 20, 2010]
  • V1.03: Miglioramenti tecnici; modifiche non funzionali. (Rifattorizzare funzioni di utilità statici in una nuova classe in ezExtras.php.) [Settembre 11, 2010]
  • V1.02: Miglioramenti tecnici; modifiche non funzionali. (Simulare namespace per evitare potenziali conflitti di nomi, correzioni di bug minori, ecc) [Settembre 4, 2010]
  • V1.01: Applicazione delle policy di Google (non più di tre blocchi di annunci). [Settembre 2, 2010]
  • V1.00: Versione iniziale. [Agosto 31, 2010]

Piano

  • Miglioramenti nella gestione Widgets. Costruzione dei mini schede. Top Corpo / mid / blocchi di annunci finali.
  • "Opzioni collegati" -- se un widget è disabilitato, le opzioni corrispondenti (il suo testo, allineamento etc) dovrebbe essere disabilitato utilizzando JS.
  • Specializzazione per Clicksor.
  • Inserire annunci Facile.
  • Miglioramenti tecnici; PHP5.0 (Funzioni __construct).

Domande frequenti

Quali sono le diverse versioni del plugin?

Facile Ads è la versione liberamente distribuita di un plugin premio. Il Pro version ti dà più vantaggi -- consente di attivare un filtro per garantire che i tuoi annunci visualizzati solo su quelle pagine che sembrano conformi al regolamento AdSense di Google. Inoltre, consente di specificare un elenco di computer in cui non verranno mostrati i tuoi annunci, al fine di evitare i clic accidentali sui propri annunci -- uno dei principali motivi AdSense vieta. Queste caratteristiche ridurre al minimo le probabilità di ottenere vietato. I costi versione Pro $8.95, ed è appropriato se si prevede di fare più di $150 di entrate pubblicitarie dal tuo sito.

Come posso contattare l'autore plug se ho bisogno di aiuto?

Questo plugin utilizza un modello di supporto a pagamento, al fine di gestire il carico di supporto. Ogni ticket di supporto sarà addebitato al $0.95 per la versione Lite (e per la versione Pro dopo un breve periodo di supporto gratuito). Il biglietto è valido per il supporto 72 orario, e altre domande di follow-up potranno chiamare per un nuovo ticket di supporto.

Io ancora non capisco. Porno e il sito del blocco - che hai già durante la configurazione ad Asdense?

Quello che hai in AdSense è la capacità di bloccare gli annunci provenienti da determinati siti. Per esempio, se non ti piace annunci da il mio sito "thulasidas.com", è possibile bloccare. Che la versione Pro offre è la possibilità di bloccare gli annunci a alcuni clienti. Questo è, se non si desidera che i visitatori da determinati indirizzi IP vedono i tuoi annunci (perché possono cliccare su troppi di loro, ottenere il vostro account AdSense vietato, per esempio), è possibile con il mio plugin di.

Blocco Porn è anche simile -- Google consente di scegliere gli annunci non-porno (Penso che). Che il mio plug fa è di guardare il contenuto della pagina, e bloccare gli annunci se sembra che una pagina porno. (Ciò può accadere se uno spammer pubblica una sorta porno di commento sul tuo blog, che ancora una volta potrebbe ottenere il vostro account AdSense vietato.)

Ho attivato i widget per vari fornitori di annunci. Ma non vedo alcuna sulle mie pagine del blog. How come?

I widget sono abilitati e disponibile sul tuo aspetto - & gt; Zona Widgets. Si prega di trascinarli alla competente side-bar.

Ottengo l'errore "Errore di individuazione o il caricamento dei valori predefiniti! Assicurarsi che esiste 'defaults.php', o reinstallare il plugin." Cosa fare?

Si prega di copiare tutto i file dell'archivio zip al vostro directory dei plugin. Avete bisogno di tutti i file nella easy-ads-lite elenco. Uno di questi file è il mancante defaults.php.

Posso attivare il plugin, ma non succede nulla. Vedo qualche messaggio di errore rosso che indica qualcosa sulla versione di PHP. Ciò che dà?

Questo plugin richiede la versione di PHP 5.x o successiva. Se non trova la giusta versione, si distacca un messaggio di errore nella pagina dei plugin, e non fa nulla. Sarà necessario contattare l'amministratore di sistema o sostenere la gente del vostro servizio di hosting e chiedere loro di installare PHP5.x per voi. Solitamente, tutto ciò che serve è solo una e-mail per farlo risolto.

Come posso controllare l'aspetto dei blocchi di annunci utilizzando i CSS?

Tutto <div>s che Facile annunci crea avere l'attributo di classe easy-ads. Inoltre, hanno attributi di classe come easy-ads-adsense-top, easy-ads-clicksor-bottom eccetera, (cioè, easy-ads-provider-position). È possibile impostare lo stile di queste classi nel vostro tema style.css per controllare il loro aspetto.

Perché il mio codice scompare quando si passa ad un nuovo tema?

Facile annunci memorizza il codice degli annunci e le opzioni nel database indicizzato in base al nome del tema, in modo che se si imposta le opzioni per un tema particolare, persistono anche quando si passa ad un altro tema. Se avete mai passa di nuovo ad un vecchio tema, tutte le opzioni saranno riutilizzati senza il vostro preoccuparsi di esso.

Ma questo significa, purtroppo, che non deve impostare il codice una volta ogni volta che si passa a un nuovo tema.

Posso controllare come i blocchi di annunci sono formattati in ogni pagina?

Sì! In Facile annunci, si hanno più opzioni [attraverso campi personalizzati] per controllare blocchi di annunci in singoli post / pagine. Aggiungere campi personalizzati con i tasti come easy-ads-adsense-top, easy-ads-adsense-middle, easy-ads-adsense-bottom e con valori come sinistra, diritto, centro o non di avere il controllo come i blocchi di annunci visualizzati in ogni post o pagina. Il valore "non" sopprime tutti i blocchi di annunci nel post o pagina per il fornitore.

WP-Plus

WP PlusQuesto e altri plugin può essere installato e gestito senza problemi con WP-Di più -- la prossima generazione di WordPress, sviluppato per il blogger professionista che richiedono plugin professionali e temi. Se sei uno sviluppatore del plugin professionale o un blogger (uno che spera di fare una vita fuori di blogging o di sviluppo blog correlati), fare il check-out!
Vedere anche:& Nbsp; & nbsp;Altri plugin
Se ti piacciono i miei sforzi dei plugin, si prega di lasciare un commento con il vostro login di Facebook qui sotto.
Se hai bisogno di aiuto, si prega di utilizzare il nostro portale di assistenza invece. & Nbsp;ezSupport Portal
[Orgogliosamente portato a voi da EZ PagareAmico.]

Commenti